Cours gratuit de comptabilité, cours gratuit informatique, cours financiers et autres cours gratuits
CoursGratuits.Net
Un site qui vous offre un accès gratuit et non conditionné à l’apprentissage simplifié
Comment Apprendre ?
Votre nouveau site de Q/R pédagogiques. les meilleures réponses sont sélectionnées et ajoutées au top réponses.
Comptabilité     Informatiques     Calculs financiers     Cours en vidéo    Annuaire de cours gratuits


Cours informatique

L'alternative avec le tableur


Objectif
    Savoir
  1. Citer et commenter, dans le cadre du calcul conditionnel, les trois sortes d’informations que peut traiter un ordinateur ;
  2. expliquer le principe de construction d’un arbre binaire de décision.
    Savoir faire
  1. écrire un arbre binaire de décision pour une alternative complexe ;
  2. Formaliser des situations d’alternative dans la forme si alors sinon et dans un graphe de Nassi-Schneiderman ;
  3. écrire une fonction alternative complexe dans le cadre d’un tableur.
     Plan
  1. Principe du calcul conditionnel: introduction au clavier
  2. Principe du calcul conditionnel: conclusion
  3. Expressions logiques non mathématiques
  4. L’alternative
  5. Ecritures de l’alternative
  6. Exercices de formulation
  7. L'alternative simple avec Excel
  8. L'alternative simple avec Excel: approfondissement
  9. Alternative complexe appliquée au jeu de dés
  10. Alternative complexe : (où l'on apprend à l'ordinateur à faire ses devoirs de maths)
  11. Comment construire une structure alternative correcte sans (trop) se fatiguer
  12. Les années bissextiles, en pratique
  13. Exercices
     Auteur auteur du cours
Mairesse Yves, enseignant depuis 1980 à l'Institut des Soeurs de Notre-Dame  à Anderlecht, est le propriétaire de ces cours d'informatique. Selon l'auteur est strictement interdit d'en faire un usage commercial et ils sont soumis au contrat Creative Commons que vous pouvez consulter en bas de page.
    Pages : | 1| 2| 3| 4| 5| 6| 7| 8 |9 |10 |11| 12| 13|

10. Alternative complexe: (où l'on apprend à l'ordinateur à faire ses devoirs de maths)

Énoncé du problème et analyse

On demande de programmer le tableur de manière à lui faire résoudre les équations du premier degré du type ax + b = 0 d'inconnue x.

Ce type de problème est élémentaire au cours de mathématiques : il se résout de la manière suivante.

alternativeIl y a ici une situation d'alternative double:

  1. Il y a un choix entre deux possibilités; pour choisir, il faut examiner le coefficient de x (il est nul ou il ne l'est pas).
  2. Si a0, il y a encore un choix entre deux possibilités; pour choisir, il faut examiner le 2ème membre de cette équation (il est nul ou il ne l'est pas).

Résultat attendu et méthode

On attend d'obtenir une feuille de calcul semblable aux exemples ci-dessous.

Pour la facilité, il serait souhaitable de nommer les deux cellules grisées a et b.

Alternative dans le tableur

Avant d'écrire le formalisme propre au tableur, nous présenterons l'alternative selon la forme

si <expression logique> alors <action1> sinon <action2>

alternative Excel

La fonction alternative s'écrira donc:

=SI(a<>0;-b/a;SI(b<>0;"Impossible";"Indéterminé"))

ou, si l'on utilise les coordonnées plutôt que les noms

=SI(A2<>0;-D2/A2;SI(D2<>0;"Impossible";"Indéterminé"))

Utilise toutes les informations données plus haut pour résoudre le problème de la résolution des équations du premier degré avec le tableur.

Quand ta feuille de calcul est prête, teste tous les cas possibles. Ensuite, montre ton travail au professeur avant de passer à la page suivante.