Cours gratuit de comptabilité, cours gratuit informatique, cours financiers et autres cours gratuits
CoursGratuits.Net
Un site qui vous offre un accès gratuit et non conditionné à l’apprentissage simplifié
Comment Apprendre ?
Votre nouveau site de Q/R pédagogiques. les meilleures réponses sont sélectionnées et ajoutées au top réponses.
Comptabilité     Informatiques     Calculs financiers     Cours en vidéo    Annuaire de cours gratuits


Cours informatique

L'alternative avec le tableur


Objectif
    Savoir
  1. Citer et commenter, dans le cadre du calcul conditionnel, les trois sortes d’informations que peut traiter un ordinateur ;
  2. expliquer le principe de construction d’un arbre binaire de décision.
    Savoir faire
  1. écrire un arbre binaire de décision pour une alternative complexe ;
  2. Formaliser des situations d’alternative dans la forme si alors sinon et dans un graphe de Nassi-Schneiderman ;
  3. écrire une fonction alternative complexe dans le cadre d’un tableur.
     Plan
  1. Principe du calcul conditionnel: introduction au clavier
  2. Principe du calcul conditionnel: conclusion
  3. Expressions logiques non mathématiques
  4. L’alternative
  5. Ecritures de l’alternative
  6. Exercices de formulation
  7. L'alternative simple avec Excel
  8. L'alternative simple avec Excel: approfondissement
  9. Alternative complexe appliquée au jeu de dés
  10. Alternative complexe : (oĂą l'on apprend Ă  l'ordinateur Ă  faire ses devoirs de maths)
  11. Comment construire une structure alternative correcte sans (trop) se fatiguer
  12. Les années bissextiles, en pratique
  13. Exercices
     Auteur auteur du cours
Mairesse Yves, enseignant depuis 1980 Ă  l'Institut des Soeurs de Notre-Dame  Ă  Anderlecht, est le propriĂ©taire de ces cours d'informatique. Selon l'auteur est strictement interdit d'en faire un usage commercial et ils sont soumis au contrat Creative Commons que vous pouvez consulter en bas de page.
    Pages : | 1| 2| 3| 4| 5| 6| 7| 8 |9| 10| 11| 12 | 13 |

12. Les années bissextiles, en pratique

La pratique pose deux problèmes:

  1. il faut être capable de déterminer si un nombre est multiple d’un autre ;
  2. il faut être capable d’écrire une alternative complexe.

Pour savoir si un nombre est divisible par un autre, il suffit de faire la division et de déterminer la valeur du reste de cette division. Les programmes tableurs mettent généralement une fonction MOD à la disposition des utilisateurs.

Dans la cellule frappe RĂ©sultat
A1 =MOD(27;5) 2, le reste de la division de 27 par 5
A2 12  
A3 =MOD(A2;A1) 0, la division de A2 par A1 a un résultat entier!

Si la cellule qui contient le millésime de l’année est nommée « AN », l’alternative s’écrira alors:

alternative complexe

Ce qui s’écrira:

=SI(MOD(AN;4)=0;SI(MOD(AN;100)=0;SI(MOD(AN;400)=0;"Bissextile";"Non bissextile");"Bissextile");"Non bissextile")

dans le formalisme propre au tableur.

Et vous auriez voulu que je trouve cette formule tout de suite en la composant directement au clavier ?

Certainement pas ! Il faut ĂŞtre un mutant pour y arriver. C'est la raison pour laquelle nous avons fait ce long raisonnement et l'effort de rĂ©-Ă©criture.

Quand tu as compris la formule pour déterminer les dates bissextiles dans le tableur, passe à la page suivante.