Cours gratuit de comptabilité, cours gratuit informatique, cours financiers et autres cours gratuits
CoursGratuits.Net
Un site qui vous offre un accès gratuit et non conditionné à l’apprentissage simplifié
Comment Apprendre ?
Votre nouveau site de Q/R pédagogiques. les meilleures réponses sont sélectionnées et ajoutées au top réponses.
Comptabilité     Informatiques     Calculs financiers     Cours en vidéo    Annuaire de cours gratuits


Cours informatique

L'alternative avec le tableur


Objectif
    Savoir
  1. Citer et commenter, dans le cadre du calcul conditionnel, les trois sortes d’informations que peut traiter un ordinateur ;
  2. expliquer le principe de construction d’un arbre binaire de décision.
    Savoir faire
  1. écrire un arbre binaire de décision pour une alternative complexe ;
  2. Formaliser des situations d’alternative dans la forme si alors sinon et dans un graphe de Nassi-Schneiderman ;
  3. écrire une fonction alternative complexe dans le cadre d’un tableur.
     Plan
  1. Principe du calcul conditionnel: introduction au clavier
  2. Principe du calcul conditionnel: conclusion
  3. Expressions logiques non mathématiques
  4. L’alternative
  5. Ecritures de l’alternative
  6. Exercices de formulation
  7. L'alternative simple avec Excel
  8. L'alternative simple avec Excel: approfondissement
  9. Alternative complexe appliquée au jeu de dés
  10. Alternative complexe : (oĂą l'on apprend Ă  l'ordinateur Ă  faire ses devoirs de maths)
  11. Comment construire une structure alternative correcte sans (trop) se fatiguer
  12. Les années bissextiles, en pratique
  13. Exercices
     Auteur auteur du cours
Mairesse Yves, enseignant depuis 1980 Ă  l'Institut des Soeurs de Notre-Dame  Ă  Anderlecht, est le propriĂ©taire de ces cours d'informatique. Selon l'auteur est strictement interdit d'en faire un usage commercial et ils sont soumis au contrat Creative Commons que vous pouvez consulter en bas de page.
    Pages : | 1| 2| 3| 4 | 5| 6| 7| 8| 9| 10| 11| 12| 13|

4. L'alternative

Introduction au clavier

Nous utiliserons la feuille de calcul entamée plus haut.

Cellule
Frappe au clavier
RĂ©sultat
Explication
E1 =SI(A1="Il fait beau";"Bronzage";"Parapluie") Le texte « Bronzage Â» apparaĂ®t dans la cellule E1 l’expression logique a Ă©tĂ© Ă©valuĂ©e (elle est vraie) et le mot « Bronzage » apparaĂ®t.
A1 Il pleut le texte « Parapluie Â» apparaĂ®t dans la cellule E1
l’expression logique a été évaluée (elle est fausse) et le premier mot (Parapluie) apparaît.
E2 =SI(A2>=10;0;1) la valeur 0 apparaît dans la cellule E2
l’expression logique a été évaluée (elle est vraie) et la première valeur apparaît.
A2 5 la valeur 1 apparaît dans la cellule E2 l’expression logique a été évaluée (elle est fausse) et la deuxième valeur apparaît.

Conclusion

La conjonction « SI » marque le début d’une alternative.

Une alternative est une situation dans laquelle deux (et seulement deux) possibilités se présentent.

Le mot « SI » est suivi d’une expression logique, qui est donc vraie ou fausse.

L’ordinateur est capable de reconnaître la situation d’alternative et d’évaluer l’expression logique. Si celle-ci est vraie, la fonction alternative retourne la valeur qui suit l’expression logique. Si l’expression logique est fausse, c’est la deuxième valeur qui est retournée.

Quand tu es capable de définir la notion d'alternative et d'exposer des exemples concrets, passe à la page suivante.